Friday, February 6, 2015

Multi Area OSPF for CCNA


This session will introduce the use, operation and configuration of Open Shortest Path First (OSPF) in multiple areas. If a single OSPF area ballooned into 400 networks, how might an OSPF topology be modified so the SPF algorithm does not overwhelm the network and so routing and link-state tables are manageable? Attend this session to learn the basics of Multi-area OSPF and use Packet Tracer 6.x to configure a Multi-area OSPF network.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Multi Area OSPF for CCNA

Please click this link to download Topology of Multi Area OSPF for CCNA

Step 1 – Initial Topology

a.      Open the Packet Tracer 6.0.1 file MultiAreaOSPF-Step1.pkt to configure the following topology.  Skip to Step 2 to bypass the necessary IP Address configuration.

b.      Configure the Hostnames and IP Addresses as shown in the following table.  Also enter the command no shutdown on each of the interfaces (except loopback interfaces)
Source
Interface
Destination
Interface
IP Address
Subnet Mask
RTA
Serial 0/0/0
RTB
Serial 0/0/0
10.1.1.1
255.255.255.252
RTA
Serial 0/0/1
RTC
Serial 0/0/1
10.1.1.5
255.255.255.252
RTA
Loopback 0
Internet

172.16.1.1
255.255.255.0
RTB
Serial 0/0/0
RTA
Serial 0/0/0
10.1.1.2
255.255.255.252
RTB
Serial 0/0/1
RTC
Serial 0/0/0
10.1.1.9
255.255.255.252
RTB
Gigabit 0/0
RTD
Gigabit 0/0
192.168.0.1
255.255.255.0
RTC
Serial 0/0/1
RTA
Serial 0/0/1
10.1.1.6
255.255.255.252
RTC
Serial 0/0/0
RTB
Serial 0/0/1
10.1.1.10
255.255.255.252
RTC
Gigabit 0/0
RTE
Gigabit 0/0
192.168.4.1
255.255.255.0
RTD
Gigabit 0/0
RTB
Gigabit 0/0
192.168.0.2
255.255.255.0
RTD
Loopback 0
LAN

192.168.1.1
255.255.255.0
RTE
Gigabit 0/0
RTC
Gigabit 0/0
192.168.4.2
255.255.255.0
RTE
Loopback 0
LAN

192.168.5.1
255.255.255.0

c.       Example, for RTA, the configuration would be as follows:

Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname RTA
RTA(config)#int s 0/0/0
RTA(config-if)#ip address 10.1.1.1 255.255.255.252
RTA(config-if)#no shutdown
RTA(config-if)#int s 0/0/1
RTA(config-if)#ip address 10.1.1.5 255.255.255.252
RTA(config-if)#no shutdown
RTA(config-if)#int loopback 0
RTA(config-if)#ip address 172.16.1.1 255.255.255.0
RTA(config-if)#exit
RTA(config)#

Step 2 – Basic OSPF Configuration

a.      Continue from Step 1 or open the file MultiAreaOSPF-Step2.pkt to begin configuring OSPF.  The initial configuration will combine RTA, RTB, and RTC into a single area (Area 0, the Backbone).
b.      Configure the serial interfaces on RTA to participate in OSPF.

RTA(config)#router ospf 1
RTA(config-router)#network 10.1.1.0 0.0.0.3 area 0
RTA(config-router)#network 10.1.1.4 0.0.0.3 area 0
RTA(config-router)#exit
RTA(config)#

c.       Now configure the serial interfaces on RTB to participate in OSPF.
RTB#config t
Enter configuration commands, one per line.  End with CNTL/Z.
RTB(config)#router ospf 1
RTB(config-router)#network 10.1.1.0 0.0.0.255 area 0
RTB(config-router)#exit
RTB(config)#
01:03:54: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.1.1 on Serial0/0/0 from LOADING to FULL, Loading Done
What is the difference in the network statements used to enable OSPF on RTA and those used on RTB?  Would you have been able to use the same command on RTB if you did not want OSPF to run on the link between RTB and RTC?


d.      Now configure the serial interfaces on RTC to also participate with OSPF.

RTC(config)#router ospf 1
RTC(config-router)#network 10.1.1.0 0.0.0.255 area 0
RTC(config-router)#
01:26:48: %OSPF-5-ADJCHG: Process 1, Nbr 172.16.1.1 on Serial0/0/1 from LOADING to FULL, Loading Done
01:26:48: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.0.1 on Serial0/0/0 from LOADING to FULL, Loading Done

Notice the adjacency changes for RTC’s neighbors when OSPF was configured.  Where did the Router ID values for RTA and RTB come from?  Which interface is 172.16.1.1 assigned to?  Which interface is 192.168.0.1 assigned to?  What command can we use to change the Router ID values so that interface values are not used?



e.       Verify that OSPF is working for RTA, RTB, and RTC in area 0.   You can use various show commands, such as show ip route, or show ipospf neighbor.  Notice there is currently only one OSPF route in the routing table for each router.

RTA#showip route
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.1.1.0/30 is directly connected, Serial0/0/0
L       10.1.1.1/32 is directly connected, Serial0/0/0
C       10.1.1.4/30 is directly connected, Serial0/0/1
L       10.1.1.5/32 is directly connected, Serial0/0/1
O      10.1.1.8/30 [110/128] via 10.1.1.2, 00:07:50, Serial0/0/0
                    [110/128] via 10.1.1.6, 00:07:50, Serial0/0/1
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.1.0/24 is directly connected, Loopback0
L       172.16.1.1/32 is directly connected, Loopback0

RTA#showipospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.0.1       0   FULL/  -        00:00:35    10.1.1.2        Serial0/0/0
192.168.4.1       0   FULL/  -        00:00:34    10.1.1.6        Serial0/0/1
RTA#

Other helpful commands to verify OSPF operation:
showipospf database
showipospf interface
debugipospfadj
debugipospf events

Step 3 – Configure OSPF Area 1

a.      Continue from Step 2 or open the file MultiAreaOSPF-Step3.pkt to configure OSPF area 1.
b.      On RTA, configure a default route for the internet interface on loopback 0.  Configure OSPF to send this route to other OSPF routers.

RTA(config)#ip route 0.0.0.0 0.0.0.0 loopback 0
RTA(config)#router ospf 1
RTA(config-router)#default-information originate

c.        Check the routing tables on RTB and RTC.  What route has now been added to the routing table for each router?  What is the type of OSPF route that has been added?  What is the LSA type associated with this type of route?  What is the metric?


d.       Configure OSPF on RTB and RTD to include the appropriate interfaces in area 1.

RTB(config)#router ospf 1
RTB(config-router)#network 192.168.0.0 0.0.0.255 area 1

RTD(config)#router ospf 1
RTD(config-router)#network 192.168.0.0 0.0.0.255 area 1
RTD(config-router)#network 192.168.1.0 0.0.0.255 area 1
RTD(config-router)#exit
00:24:40: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.0.1 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

e.      Verify that RTD has both inter-area routes (IA) and the external (E2) route displayed in the routing table.

RTD#shoip route
Gateway of last resort is 192.168.0.1 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 3 subnets
O IA    10.1.1.0/30 [110/65] via 192.168.0.1, 00:00:07, GigabitEthernet0/0
O IA    10.1.1.4/30 [110/129] via 192.168.0.1, 00:00:07, GigabitEthernet0/0
O IA    10.1.1.8/30 [110/65] via 192.168.0.1, 00:00:07, GigabitEthernet0/0
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.0.0/24 is directly connected, GigabitEthernet0/0
L       192.168.0.2/32 is directly connected, GigabitEthernet0/0
     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Loopback0
L       192.168.1.1/32 is directly connected, Loopback0
O*E2 0.0.0.0/0 [110/1] via 192.168.0.1, 00:00:07, GigabitEthernet0/0

f.        View the Link State Database on RTD with the command show ipospf database.  What is the LSA type associated with the inter-area (IA) routes?  Which LSA type is associated with the default route advertised by RTA?



Step 4 – Configure OSPF Area 2.  Configure the area as a Stub area.

a.      Continue from Step 3 or open the file MultiAreaOSPF-Step4.pkt to configure OSPF area 2.

b.      Configure RTC for OSPF operation on Gigabit Ethernet 0/0 in area 2.

RTC(config)#router ospf 1
RTC(config-router)#network 192.168.4.0 0.0.0.255 area 2
RTC(config-router)#area 2 stub

c.       Configure RTE for OSPF operation in area 2.

RTE(config)#router ospf 1
RTE(config-router)#network 192.168.4.0 0.0.0.255 area 2
RTE(config-router)#network 192.168.5.0 0.0.0.255 area 2
RTE(config-router)#area 2 stub

d.      Use the show ip route command on RTE to verify that OSPF routing information has been received from RTC.  Is there any difference between the number and type of routes shown when compared to those previously seen on RTD?  Does RTE have any routes listed that are in area 1?

e.      Use the show ipospf database command on RTE to view the LSA types received.  Are there differences in the LSAs received by RTE when compared to those previously seen on RTD?

f.        On RTD, use the show ip route command to view the current routing table.  Does RTD have any routes listed that are in area 2?

g.      Verify on RTD that you are able to reach both the route for the internet (172.16.1.1) and the route for the LAN on RTE (192.168.5.1).

RTD#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/11 ms

RTD#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

h.      Verify on RTE that you are able to reach both the route for the internet (172.16.1.1) and the route for the LAN on RTC (192.168.1.1).

RTE#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/10 ms

RTE#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/6 ms

i.        Change area 2 to be configured as a totally-stubby area.

RTC(config)#router ospf 1
RTC(config-router)#area 2 stub no-summary

j.        Use the show ip route command on RTE to view the changes to the routing table now that area 2 is configured as totally-stubby.

RTE#ship route
Gateway of last resort is 192.168.4.1 to network 0.0.0.0

     192.168.4.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.4.0/24 is directly connected, GigabitEthernet0/0
L       192.168.4.2/32 is directly connected, GigabitEthernet0/0
     192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.5.0/24 is directly connected, Loopback0
L       192.168.5.1/32 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 192.168.4.1, 00:14:04, GigabitEthernet0/0

Notice that since RTE has 192.168.4.0 and 192.168.5.0 networks directly connected, there are no OSPF routes listed with the ‘O’ designation (intra-area).  Which route will be used to reach networks in area 0, area 1, and the internet?


Verify that both the 192.168.1.1 and 172.16.1.1 routes are still reachable.

RTE#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

RTE#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

k.       On RTE, use the show ipospf database command to view the LSA types now being sent from RTC.  How does changing the type of area affect the LSA types seen in that area?


Step 5 – Configure area 2 as an NSSA. 

a.      Continue from Step 4 or open the file MultiAreaOSPF-Step5.pkt to configure area 2 as a Not So Stubby Area (NSSA).

b.      On RTE, network 192.168.5.0 will now be used to reach a network that is not native to OSPF.  This would normally create a type 5 LSA (same as that used for the internet connection 172.16.1.1), but type 5 LSAs are not allowed in stub or totally-stubby areas.  Remove network 192.168.5.0 from OSPF and add it to EIGRP in AS 100.

RTE(config)#router ospf 1
RTE(config-router)#no network 192.168.5.0 0.0.0.255 area 2
RTE(config-router)#exit
RTE(config)#router eigrp 100
RTE(config-router)#network 192.168.5.0 0.0.0.255

c.       RTD now will not be able to reach the 192.168.5.1 address on RTE as it is no longer being advertised.

RTD#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

d.      Change the area type for area 2 to be an NSSA area, first by removing the configuration for totally stubby, then by adding the NSSA configuration.

RTE(config)#router ospf 1
RTE(config-router)#no area 2 stub
RTE(config-router)#area 2 nssa

RTC(config)#router ospf 1
RTC(config-router)#no area 2 stub no-summary
RTC(config-router)#area 2 nssa

Note:  If necessary you can force OSPF to renegotiate neighbor connections by shutting down the link between neighbors, or reload one (or both) routers.

e.      Redistribute the EIGRP route into OSPF on RTE to allow it to be advertised throughout the OSPF network.

RTE(config)#router ospf 1
RTE(config-router)#redistribute eigrp 100 subnets
RTE(config-router)#

f.        Verify that RTD can now once again reach the 192.168.5.1 address.

RTD#ping 192.168.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/12 ms
(Note that since we have not redistributed any routes from OSPF into EIGRP, if this was for an ethernet or serial interface full connectivity would not be achieved beyond this network.)

g.      On RTD, what is the type of route associated with the 192.168.5.0 network?  Use the show ip route command.  Using the show ipospf database command, what type of LSA is being used for RTD to learn of this network?

Network 192.168.5.0
Routing Table -  Network Type:

LSDB -  LSA Type:

h.      On RTC, what is the type of route associated with the 192.168.5.0 network?  Use the show ip route command.  Using the show ipospf database command, what type of LSA is being used for RTD to learn of this network?

Network 192.168.5.0
Routing Table -  Network Type:

LSDB -  LSA Type:



No comments:

Post a Comment